Cart
 

EmotivXavierControlPanel : MentalCommands menu crashes my Mac

Home Forums Emotiv Main Forum Applications & Games EmotivXavierControlPanel : MentalCommands menu crashes my Mac

This topic contains 4 replies, has 3 voices, and was last updated by  Timothy Shea 1 year ago.

  • Author
    Posts
  • #119330

    EmotivXavierControlPanel, MentalCommands, Mac, MaOS

  • #235305

    Hi Emotiv Team,

    I’ve been playing with the Insight for a few days.
    My first objective is to train some mental commands.

    I’d like to use the EmotivXavierControlPanel – which seems more reliable than the webApp.
    However: I was only able to access the MentalCommands menu once (during which the screen was displayed correctly).
    I was interrupted at that time, and had to stop after just beginning the first training.

    Now, when I click on the MentalCommands menu, my Mac crashes… (screen gets filled with bizarre lines & I have no choice but to reboot).
    I tried uninstalling / installing again, but to no avail.

    Thanks for the help,
    Ben

    PS: I plan an building on top on Control Panel (with IEE_EngineRemoteConnect() it seems) – so as of now I can’t really move forward with building a prototype

  • #235315

    gmac
    Keymaster

    Hi Benjamin, please email our support team: hello at emotiv dot com
    Include your order number, Mac OS version and the version of Xavier Control Panel you are using

  • #235326

    Thanks gmac, just did that.
    If I get a solution – which I certainly hope 😉 – I’ll post it here.

  • #235545

    Timothy Shea
    Member

    I had a similar problem. Macbook Pro, running Win 7 64-bit in Parallels.

    Was able to access mental commands reliably for a few hours (Xavier Control Panel 3.1.19). Then my screen went berserk. Strange graphics pyrotechnics. I shut down Windows 7. Then Parallels Desktop. The graphics problems persisted into Mac OS. So I attempted to reboot Mac OS.

    At this point, my computer was unbootable. Reboot got as far as the apple logo and progress bar, but with strange vertical bands on a washed out screen. After partial progress bar, the display went gray, and hung there. Attempted to reboot in safe mode, hardware diagnostics mode, same thing. This computer has been very reliable, never did this before. (Early 2011 Macbook Pro 17′, OSX 10.10.5, i7, 16GB RAM, 1TB SSD, Parallels Desktop, Windows 7 Pro 64-bit SP1, recent, clean installs of both operating systems, and new install of all Emotiv software the day before.)

    For me, it turned out to be a problem with the Macbook Pro automatic graphics switching. Macbook Pros of this vintage (2011) have two graphics chips. And the higher performance one (AMD Radeon hd 6750m, in my case) is known to be problematic due to manufacturing defects. When Mac OS tried to switch to the higher performance chip, it crashed the display, and the system became unbootable.

    I fixed it by:

    1. Left the mac turned off and unplugged overnight. (Resets the SMC and/or PRAM, I guess, though I’ve since learned there are keyboard commands for this.) The next morning it successfully rebooted.
    2. I went to Energy Saver -> Automatic Graphics Switching, and disabled it. This forces the Mac to use built-in video, which is slower but seems to work. (If your Mac is booting, this may be all you need to do.)

    Ran the Xavier Control Panel. No problems since. Not sure if this is your problem, but seems to have fixed mine.

    References:

    General explanation of Macbook Pro integrated video: https://support.apple.com/en-us/HT204349 (Apple)
    Issues with the AMD graphics chip: https://www.google.com/search?&q=amd+radeon+hd+6750m+macbook+pro (Google search)

The forum ‘Applications & Games’ is closed to new topics and replies.